Washers stop washin

Discussion in 'GMC Truck Forum' started by gmctrucks, Sep 7, 2017.

  1. 96silverado

    96silverado Full Member

    Joined:
    Sep 23, 2012
    Messages:
    2,634
    Likes Received:
    3,708
    Trophy Points:
    113
    These look like they are kinda cold soldered, maybe re-solder these two.
     

    Attached Files:

  2. gmctrucks

    gmctrucks Full Member

    Joined:
    Nov 9, 2006
    Messages:
    8,750
    Likes Received:
    4,409
    Trophy Points:
    113
    Location:
    Houston,Texas
    They fooled me as well but it's just two plastic tabs holding the board
     
    96silverado likes this.
  3. kbrown11

    kbrown11 Full Member

    Joined:
    Dec 5, 2015
    Messages:
    1,162
    Likes Received:
    2,016
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    Customer Service Representative
    Location:
    Alburquerque
    Is there power to your pump?
     
    gmctrucks likes this.
  4. gmctrucks

    gmctrucks Full Member

    Joined:
    Nov 9, 2006
    Messages:
    8,750
    Likes Received:
    4,409
    Trophy Points:
    113
    Location:
    Houston,Texas
    #14 gmctrucks, Oct 10, 2017
    Last edited: Oct 10, 2017
    Ok guys I have been dealing with the same thing no washer pump action so I bought the pump mine was rusted up bad and I said I’m not even going to ohm it out because it’s in bad condition so I bought a new pump put it on without primIng it and it’s a no go so I finally checked for power again and I did have a bad ground when I checked it the first time with my test light so I used the brake line and I do have power going to my pump BUT what I noticed is the new pump has no ground for it to plug into with the factory plug like the original one did so maybe I just bought a defective pump I’m going to return it instead of grounding it out.

    Have any of you guys seen this before?

    Ok guys I confirmed with O’ Reileys auto parts that the pump came defective it’s missing the ground prong.
     

Share This Page