Transmission problems - 4L60E

Discussion in 'Chevy Truck Forum' started by Plyc1500, Aug 2, 2013.

  1. Plyc1500

    Plyc1500 Full Member

    Joined:
    Sep 26, 2010
    Messages:
    63
    Likes Received:
    17
    Trophy Points:
    8
    Hey Chevy -
    I'm having an issue with my '97 C1500 (4.3L, 4L60E trans). It's now got 394,000 miles on it and I was really hoping to get 400K but it doesn't look like I will so any help would be appreciated. The body and under carriage are shot but she always ran great (all day at 90MPH without complaints).

    Anyway, the other day, I was coming home from work and the truck just started coasting... like it popped out of gear and when I gave it more throttle, the engine just revved like it was in neutral (though the indicator always read Drive). Coasted off the road (for once a rest area when I needed it was right there) and stopped.

    Ran the shift lever through the positions and it felt sloppy and the gear shift indicator sometimes wouldn't even point to the correct gear. Through a series of maneuvers, I was able to make it home.
    I had replaced the Neutral Safety Switch last year due to backup light issues so I figured that was it again. Got a new one at AAP, put it in and same thing. It doesn't seem to know what gear it's in. Sometimes, it only has reverse and a few minutes later, it won't have reverse but only moves forward.

    Is it as bad as I think it is?
    Truck is not worth putting money into but I don't mind putting time into it so I can get it to 400K.

    Thanks
     
  2. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,473
    Likes Received:
    13,299
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Sounds like the switch or the fuse has blown? Check fuse 16 i think in fuse panel. Also do this check fluid when cold notice where it is on dip stick.
    Then start the truck..get warmed up check fluid to see if it has any movement/drop on dip stick. But sounds like switch..no right shift indicator??
    Did you install right? Sure acts like pcm does not know what gear it is in..check grounds..pcm grounds all to shift.
    Weird it done it going down the highway? PCM/ECM GROUNDS THESE FOR SHIFTS..OR TELLS WHAT GEAR YOUR IN.
    Can you manually shift any..look this over see what best fits your symptoms 30 Common 4L60E Transmission Problems & Repair | Charlotte NC Need to find a wiring diagram ..could also be ignition switch maybe?
    If converter went..would do this..but the indicator..has to be electrical?
    [​IMG]
     
    2 people like this.
  3. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,473
    Likes Received:
    13,299
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Wore out tonight worked much today no not drinking lol ...most of that from thinking tired..all over the place but need to check all also check for codes. here is the diagrams.
    [​IMG][​IMG]
     
  4. Plyc1500

    Plyc1500 Full Member

    Joined:
    Sep 26, 2010
    Messages:
    63
    Likes Received:
    17
    Trophy Points:
    8
    Error code is P0102 MAF or VAF low input.
    Couldn't imagine that would cause all these transmission problems however?
     
  5. dirtrider73068

    dirtrider73068 Senior Moderator
    Staff Member

    Joined:
    Jul 14, 2011
    Messages:
    6,924
    Likes Received:
    4,440
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    dump trucker driver
    Location:
    Central Oklahoma
    Do you have any drive or reverse at all? If not it may be the pump is shot.
     
  6. Plyc1500

    Plyc1500 Full Member

    Joined:
    Sep 26, 2010
    Messages:
    63
    Likes Received:
    17
    Trophy Points:
    8
    There seems to be always something... but often it like it starts off in 3rd or 4th gear.
    Once I get to a certain speed (in 3rd/4th from a dead stop) it downshifts to 2nd (probably via TV cable), picks up speed and then could be okay or just jump into neutral (nothing)... gearshift indicator stays where it was.
    Reverse is spotty... sometimes there & sometimes not.
     
  7. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,473
    Likes Received:
    13,299
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Check fuses first thing...check for 12 volts on the maf pink wire. Should be 12 volts..might be your problem .. a ignition fuse blown.
    Here is the diagnostics on the maf.ww2.justanswer.com/uploads/Bluegorilla/2009-10-13_135224_1997_w_p0102.pdf
     
  8. chevychase

    chevychase Semi-Admin
    Staff Member

    Joined:
    Oct 15, 2010
    Messages:
    22,473
    Likes Received:
    13,299
    Trophy Points:
    113
    Occupation:
    SELF EMPLOYED
    Location:
    truck forum .org
    Link not work..seems your truck is in limpmode..will only get 2nd and reverse. Check all fuses.
    There is no tv cable on yours see if this link works Then, like a reference guide check this TSB DTC P0102 MAF
     
  9. Plyc1500

    Plyc1500 Full Member

    Joined:
    Sep 26, 2010
    Messages:
    63
    Likes Received:
    17
    Trophy Points:
    8
    Okay.. thanks. Checked all fuses. Everything OK (even ohmed them out to make sure they were good).
    I'll check the voltage tomorrow per diagram.

    Thanks
     
  10. bjackson

    bjackson New Member

    Joined:
    Apr 4, 2014
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    0
    1 person likes this.

Share This Page