TBI Issues

Discussion in 'Chevy Truck Forum' started by BluRock, Mar 1, 2017.

  1. BluRock

    BluRock Member

    Joined:
    Mar 1, 2017
    Messages:
    13
    Likes Received:
    6
    Trophy Points:
    3
    Gender:
    Male
    Trying to figure out why engine wont start after replacing fuel tank, pump and filter. Have disassembled TBI and determined injectors are clicking using a 9 volt battery. Have fuel pressure to TBI. Will start when I pour gasoline into venturi. I know the truck well as I bought it new in 1988. Was running fine until it decided to not run anymore. After setting for a while (months) I decided to do repairs, i.e., replace items mentioned above. Engine turns over normal. Looking for help in getting Ole Blue running again.
     
  2. jkeaton

    jkeaton Full Member

    Joined:
    Nov 21, 2013
    Messages:
    3,125
    Likes Received:
    5,213
    Trophy Points:
    113
    Occupation:
    Engineer
    Location:
    Winston Salem, NC
    You have fuel pressure to the TBI, but is it actually spraying fuel into the venture while attempting to start?
     
  3. BluRock

    BluRock Member

    Joined:
    Mar 1, 2017
    Messages:
    13
    Likes Received:
    6
    Trophy Points:
    3
    Gender:
    Male
    Is not spraying from injectors. Ascertained fuel to TBI by disconnecting fuel line and tapping power at battery while key in on position. Pouring fuel in manually does start engine but does not continue running after it burns off.
     
  4. kbrown11

    kbrown11 Full Member

    Joined:
    Dec 5, 2015
    Messages:
    1,233
    Likes Received:
    2,158
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    Customer Service Representative
    Location:
    Alburquerque
    What is the fuel pressure reading with key on?
     
  5. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    12,763
    Likes Received:
    7,919
    Trophy Points:
    113
    Location:
    N.Y.
    keep dribbling for about a min, see if it continues, if so ecm temp switch...

    check for rotted fuel line, as mentioned change fuel filter
     
  6. BluRock

    BluRock Member

    Joined:
    Mar 1, 2017
    Messages:
    13
    Likes Received:
    6
    Trophy Points:
    3
    Gender:
    Male
     
  7. BluRock

    BluRock Member

    Joined:
    Mar 1, 2017
    Messages:
    13
    Likes Received:
    6
    Trophy Points:
    3
    Gender:
    Male
    After cleaning injectors good, replacing screens and reassembling throttle body, engine fired right up this morning. Ran like a top. Let it run for about 10 minutes, backed it out of the shop and turned it off; wouldn't start back up. Mashed pedal to open butterflies and it tried to crank but was acting like the timing was off. Afraid to drive it any distance until I'm confident it's running normal. I bought a new MAP sensor but didn't install it, seemed to run OK without doing so,,,, I thought. My understanding of the MAP sensor should not make the timing sound off, or do I have a misunderstanding!
     
  8. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    12,763
    Likes Received:
    7,919
    Trophy Points:
    113
    Location:
    N.Y.
    an ecm coolant temp switch or oil pressure switch would do that

    prime it and see if it runs
     
  9. BluRock

    BluRock Member

    Joined:
    Mar 1, 2017
    Messages:
    13
    Likes Received:
    6
    Trophy Points:
    3
    Gender:
    Male
    All is well! Removed EGR valve and cleaned good (it was stuck). Put new MAP sensor on and this truck runs like a new one. Thanks for the advice on this forum.
     
    MrMarty51, leolkfrm and kbrown11 like this.
  10. BluRock

    BluRock Member

    Joined:
    Mar 1, 2017
    Messages:
    13
    Likes Received:
    6
    Trophy Points:
    3
    Gender:
    Male
    Back again! Truck been running like a top. Got in it this morning and it would start. Finally started but had very rough idle until it warmed up. Throttle response not as good as it was a few days ago either. What in the world is causing this?
     

Share This Page