2008 1500 no power when key turned on

Discussion in 'Dodge Truck Forum' started by Robert78.5, Jan 16, 2018.

  1. Robert78.5

    Robert78.5 Full Member

    Joined:
    Sep 10, 2006
    Messages:
    104
    Likes Received:
    1
    Trophy Points:
    18
    Occupation:
    Sales manager
    Location:
    Manitoba
    no power when key turned on, battery is good. what could it be,
     
  2. MikeG

    MikeG Full Member

    Joined:
    Feb 26, 2011
    Messages:
    2,923
    Likes Received:
    2,165
    Trophy Points:
    113
    Occupation:
    Wind Turbine Technician
    Location:
    gmtruckclub.com
    :idea: Bad Ignition Switch.......?
     
    gmctrucks likes this.
  3. gmctrucks

    gmctrucks Full Member

    Joined:
    Nov 9, 2006
    Messages:
    9,139
    Likes Received:
    4,880
    Trophy Points:
    113
    Location:
    Houston,Texas

    I bet yours is just like this one but this is what MG is talking about also check your battery as well it could have died as well but if your lights turn on then MG is right on the button I’m thinking it’s the switch as well.
     
  4. Robert78.5

    Robert78.5 Full Member

    Joined:
    Sep 10, 2006
    Messages:
    104
    Likes Received:
    1
    Trophy Points:
    18
    Occupation:
    Sales manager
    Location:
    Manitoba
    It is strange acting, tried starting at -30, block heater plugged in, turned key and dash lights flickered and nothing. Put booster on and nothing. no oil light, no radio, no heater fan, but when key is turned on break lights come on at back. I turned on hazard lights switch and nothing. Checked all grounds i could see and everything is clean and tight. Checked fuses and relays all good. When i turned on cargo light to see if it worked it came on and door chime started to chime with door open, when cargo light turned off door chime stopped. Not sure what to try next.
     
  5. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    12,763
    Likes Received:
    7,919
    Trophy Points:
    113
    Location:
    N.Y.
    bad cable connections, battery, ground to chassis, post at starter, corrosion inside of cables
     
    MikeG likes this.
  6. jkeaton

    jkeaton Full Member

    Joined:
    Nov 21, 2013
    Messages:
    3,125
    Likes Received:
    5,213
    Trophy Points:
    113
    Occupation:
    Engineer
    Location:
    Winston Salem, NC
    Have you actually had the battery load tested? May be enough power to turn on lights, not enough to turn the engine over. May be a dead cell...
     
    MikeG likes this.
  7. Robert78.5

    Robert78.5 Full Member

    Joined:
    Sep 10, 2006
    Messages:
    104
    Likes Received:
    1
    Trophy Points:
    18
    Occupation:
    Sales manager
    Location:
    Manitoba
    Never load tested battery, but have a large booster on it.
     
  8. leolkfrm

    leolkfrm Full Member

    Joined:
    Mar 2, 2008
    Messages:
    12,763
    Likes Received:
    7,919
    Trophy Points:
    113
    Location:
    N.Y.
    can have 3 batteries, if the cables are bad it will not power the truck
     
    MikeG likes this.

Share This Page