Oldmech
Last Activity:
Mar 12, 2017 at 8:30 AM
Joined:
Jan 12, 2010
Messages:
1,763
Likes Received:
214
Trophy Points:
63
Birthday:
Apr 12, 1964 (Age: 52)
Location:
Iowa
Occupation:
Retired

Share This Page

Oldmech

Full Member, 52, from Iowa

Oldmech was last seen:
Mar 12, 2017
    1. onthethreshold
      onthethreshold
      Glad to see you back,place doesn't seem the same without you .
    2. MikeG
      MikeG
      Just wanted to up date you. I checked all my connections with a UV light and didn't see any evidance of a leak. I checked the system a few days later and it is holding at 50 psi. I think I got it! Thanks again for your help.
    3. MikeG
      MikeG
      Not a problem on the response time, I had Firestone look at it and they came up with $400 worth of work. I posted a thread, 60 Bucks In The Wind, explaining it. Long story short I replaced the hose (drier to condensor), orfice tube, and charged the system. Of course 2 days later it all leaked out. I think that was because the o-ring I replaced at the orfice tube was a little larger than the original and didn't get a good seal. I've done this on different lines on the Tanks (M1 Abrams) in the motorpool and never had an issue, so I didn't think nothing of it. I put the old o-ring back in, since there was nothing wrong with it, and hopefully that fixed it. After checking it with the guage it lost some pressure over the past 3 or 4 days; I'm getting ready to go out and check it with the UV light now that the sun has gone down. Thanks brother, Mike
    4. MikeG
      MikeG
      I got an appointment to take it to Firestone on Fri to check out the system. Of coarse it has to be 105+ on the day I'm taking it in!!!!!! :no:
    5. MikeG
      MikeG
      Oldmech, I have an AC question I hope you can answer for me since I don't know much about them. In a nut shell, the system in my '96 5.7L K1500 doesn't work. The AC light comes on when the button is pushed, but it doesn't feel, look, or sound like the compressior kicks on. I bought the truck 2 yrs ago and found out last summer that it didn't work. If it is out of freon does it keep the system from turning on? I read in another post that you replied to about low freon and the system not working.... and something about the low pressure switch...... this is about where my brain fried! Would taking it to a shop to check the freon or the system be a good start, or should I do any checks myself first? I don't want a shop to fix things that are not broken; since here in Kansas it seems that raking a Soldier over the coals is a common thing. Can you offer any help to a back yard Army mechanic?? Thanks Mike
    6. rick6502
      rick6502
      oldmech, not having much luck getting my question answered..posted in chevy truck forum...1992 chevy silverado 4x4 not locking in...actuator is working...removed it and tryed to move the shift rod with a screwdriver...can only feel maybe a 1/4 inch of movement with spring tension...doesnt feel like any movement of the shift fork...question....if I remove the axle tube will that allow access to the shift fork and connecting gear?
    7. onthethreshold
      onthethreshold
      New here,how do I add a pic on my profile instead of that mannequin that comes up?I like the good advice you give.Thanks for your help.By the way my name is Donnie and heres my email as I don't think the rest of the group wants to read this. on_the_threshold_of_a_dream@hotmail.com
    8. joser559
      joser559
      hey buddy its been a while since my last post on here. I have been working here and there and the truck has lost some of dedication I had for it.......bills and what not. Anyways I was looking around on the threads and I did not find any answers for what I am looking for. My power steering return line has been leaking where the return line connects to the pump. I replace it originally because the metal line was leaking so I replaced it with a high pressure line with metal fittings connected to a high pressure hose in the middle. So when I drove it the next day the fluid was leaking. I removed the line and replaced the rubber gasket and tightened it but again I'm leaking...any ideas??? Also can you tell me if my truck has hydro boost??? I also need to replace the seals on the master cylinder for the brakes....Is it the 1 1/8 do you know??? Since I'm working late hours I have no time to work on the truck.....and since I have no garage to work on it .......it sucks. Thanks in advance for any help you can give me.....
    9. fordson
      fordson
      Thanks so much i give him this ifo so he can get us some parts.
    10. fordson
      fordson
      Hey i no your the man for this question i am helping my nephew on his 87 custom deluxe 10 series 305 engine as you no this was the transition year this truck is fuel injected we need the saddle straps and bands for the gas tank and the sending unit as well he has contacted alot of parts places and they don't have a part number for anything other than the tank it's self i thought you could send us in the right direction. thanks
  • Loading...
  • Loading...
  • About

    Birthday:
    Apr 12, 1964 (Age: 52)
    Location:
    Iowa
    Occupation:
    Retired
    # Trucks:
    omg!!!
    Truck Makes/Models:
    OMG again!
    Free Entry:
    Theres something about, buying a three hundred dollar truck, and making it new again that fills the voids in my life now that the kids are out on their own.
    Facebook/ Scott Sievers I am always up for talking trucks, theres a few pics and vids on my page, make sure to check the older posts!
    Retired mechanic, several years as a GM Truck mechanic

    primary hobby is restoring GM Trucks, very old, up to about 94