leolkfrm's Recent Activity

  1. leolkfrm replied to the thread Stock wheels.

    full hubcaps

    Jul 23, 2017 at 1:02 PM
  2. leolkfrm replied to the thread Exhaust questions.

    nope summit has a good price for the complete set up @150 for both

    Jul 23, 2017 at 12:59 PM
  3. leolkfrm replied to the thread 1999 Tahoe 4x4 front suspension..

    should have added, using a big pair of channel locks, they should not have play when pulled together

    Jul 23, 2017 at 4:53 AM
  4. leolkfrm replied to the thread Exhaust questions.

    oem for years did not have gaskets, started using gaskets with studs and thin-wall cast manifolds

    Jul 23, 2017 at 4:51 AM
  5. leolkfrm replied to the thread 1999 Tahoe 4x4 front suspension..

    yes

    Jul 22, 2017 at 8:19 PM
  6. leolkfrm replied to the thread replacing only one rod??.

    i would have the rest checked, can not see a fracture, also need to look at piston skirts and wristpins what year engine?

    Jul 22, 2017 at 2:24 AM
  7. leolkfrm replied to the thread New Problem-Running rough.

    may be an intake manifold gasket, check under dist cap

    Jul 21, 2017 at 3:12 AM
  8. leolkfrm replied to the thread 1983 chevrolet c10 no crank.

    sounds like you are close.....question is why did they blow, has a wire rubbed some where?

    Jul 21, 2017 at 3:09 AM
  9. leolkfrm replied to the thread 4.3 v6-5.7 350.

    yes

    Jul 21, 2017 at 3:05 AM
  10. leolkfrm replied to the thread Exhaust questions.

    how much you want to spend would be the determining factor, price out pars thru summit

    Jul 21, 2017 at 3:04 AM
  11. leolkfrm replied to the thread tbi problem 93 5.7??.

    usually if gas is not leaking from a tb its ok, think i would look under the cap and make sure all is ok

    Jul 19, 2017 at 3:01 AM
  12. leolkfrm replied to the thread tbi problem 93 5.7??.

    when did it get its last tuneup? cap rotor wires plugs?

    Jul 18, 2017 at 3:28 AM
  13. leolkfrm liked zell66's post in the thread 1996 k2500 suburban, dead need help fast.

    Well I feel STUPID!!! wires were so corroded it needed a good clean and she fired right up.

    Jul 17, 2017 at 4:39 AM