JTWard's Recent Activity

  1. JTWard replied to the thread Something new something Old.

    That Dark oak looks real nice in the kitchen Smoky ! That profile pic is great. It looks like the first one except this one is brand new...

    Mar 29, 2017 at 5:57 PM
  2. JTWard liked smokybandit's post in the thread Something new something Old.

    Another small update: Took the dining table and cut it down to 24" wide. Increased room for walking around in Kitchen area. [ATTACH]...

    20170327_102006.jpg 20170327_102020.jpg Mar 29, 2017 at 5:55 PM
  3. JTWard liked gmctrucks's post in the thread 4.3L swap with 350.

    Harry why are you wanting to get rid of it? I think if you do a little work on it that engine might whip a 5.7 and change out the...

    Mar 29, 2017 at 5:25 PM
  4. JTWard liked smokybandit's post in the thread 4.3L swap with 350.

    They make adapter kits. Otherwise you may have too much power for the transmission to handle.

    Mar 29, 2017 at 5:25 PM
  5. JTWard attached a file to the thread TBI Issues.

    Congratulations on your finding the trouble. It always feel great the first time you fire it up for the first time with fresh ignition....

    SANY0535.JPG SANY0534.JPG Mar 27, 2017 at 1:20 PM
  6. JTWard liked BluRock's post in the thread TBI Issues.

    Wow! Pulled distributer cap off for the first time since buying the truck in 1988 and couldn't believe it ran at all. Lots of...

    Mar 27, 2017 at 1:14 PM
  7. JTWard liked smokybandit's post in the thread Something new something Old.

    Just roll back to page one on this Thread if you want to see what it use to look like.

    Mar 27, 2017 at 12:14 PM
  8. JTWard replied to the thread 2014 silverado.

    If there is a recall on your truck, take to a Chevrolet Dealership and have them fix the recalled part. It is on them to pay for it. If...

    Mar 26, 2017 at 4:27 PM
  9. JTWard replied to the thread electrical problem.

    I'm a trifecta vote here. Sounds like a poor ground. The electrical circuit needs a good battery as a start, and a good clean ground....

    Mar 25, 2017 at 5:24 PM
  10. JTWard liked MrMarty51's post in the thread electrical problem.

    I too am suspecting a bad ground. Also check the grounding strap that is right behind the cylinder head on the right hand side. Check...

    Mar 25, 2017 at 5:18 PM
  11. JTWard liked scavanger's post in the thread electrical problem.

    if it were mine I would do an in depth cleaning of ALL grounds I could find. Also make sure you don't have bad ends on the battery...

    Mar 25, 2017 at 5:18 PM
  12. JTWard replied to the thread Something new something Old.

    Hay Smoky, Wow is all I can say. For member who didn't have a chance to see the "Original" I don't think they can appreciate what you...

    Mar 24, 2017 at 1:18 PM
  13. JTWard liked smokybandit's post in the thread Something new something Old.

    Minor update mostly installed metal barrier and prepped the generator box before install. [ATTACH] [ATTACH] [ATTACH]

    20170322_133219.jpg 20170322_133227.jpg 20170322_150202.jpg Mar 24, 2017 at 1:10 PM
  14. JTWard replied to the thread TBI Issues.

    Great News, but if you would pull the codes from the OBD-I system, it would open a whole new take on things ?

    Mar 24, 2017 at 1:07 PM
  15. JTWard liked BluRock's post in the thread TBI Issues.

    Truck been running like a new one, no spitting, sputtering lots of power. All of a sudden, Engine dies, no warning. Replaced coolant...

    Mar 24, 2017 at 1:06 PM